Power Grid Failure Telford
Incident Report for Exascale
Resolved
Power has been restored to neighbouring estates and we've maintained grid power to our POP site. Closing incident.
Posted Jan 11, 2021 - 12:54 UTC
Update
Neighbouring housing estates are still seeing power failure, we will continue to monitor.
Posted Jan 11, 2021 - 10:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2021 - 10:03 UTC
Update
The grid has been restored and we're now behind the rectifier and off battery.
Posted Jan 11, 2021 - 10:02 UTC
Investigating
We're currently experiencing a power grid failure at our Telford POP site, the site is still online however via battery backup.
Posted Jan 11, 2021 - 09:53 UTC
This incident affected: Exascale - Core and Edge Networks (Telford (TEL00)).