Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 19, 2023 - 19:00 GMT
Scheduled
During this window we will be increasing the port size between Exascale and Cogent Communications. All traffic destine for Cogent Communications will utalise GTT in London.
Posted Jan 16, 2023 - 19:43 GMT
This scheduled maintenance affected: Exascale - Core and Edge Networks (Manchester (MCR00)).