Loss of Mains Power to Telford Network Site

Incident Report for Exascale

Resolved

All systems have been stable for a number of hours. We're now closing this incident.
Posted Jul 01, 2022 - 17:31 BST

Monitoring

Western Power has resolved the fault and we're now back on mains. We will continue to monitor the situation.
Posted Jul 01, 2022 - 15:12 BST

Identified

Western Power Distribtion have identified a faulty cable outside our network site. We have lost mains supply while its being repaired. We're currently running on battery while we await the delivery of an emergency generator.
Posted Jul 01, 2022 - 14:08 BST
This incident affected: Exascale - Full Fibre Networks (Telford) and Exascale - Core and Edge Networks (Telford (TEL00)).