Maintenance complete. We have observed all circuits return back to service which were effected by these works.
Posted Jun 27, 2022 - 21:31 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2022 - 18:00 UTC
Scheduled
During this maintance window we will be relocating fibre optic joint Nr Hortonwood West. The maintenance will affect all circuits to Hortonwood West / Leasowes Court for the duration of the maintenance window.
Posted Jun 23, 2022 - 09:39 UTC
This scheduled maintenance affected: Core and Edge Networks (Telford (TEL00)).