DDOS Protection Outage - Affecting public facing websites

Incident Report for Exascale

Update

Unfortunately we have seen services via CloudFlare revert to being offline. We await updates.
Posted Nov 18, 2025 - 12:01 GMT

Update

We're starting to see websites recover. We await further updates from CloudFlare.
Posted Nov 18, 2025 - 11:56 GMT

Identified

We are experiencing an outage with all websites and services protected by CloudFlare.
Posted Nov 18, 2025 - 11:53 GMT
This incident affects: Exascale - Business Systems (Website DDOS Protection).