Storm Éowyn Update
Incident Report for Exascale
Resolved
The Exascale network didn’t incur any damage as part of this weather event.
Posted Jan 29, 2025 - 01:07 GMT
Monitoring
We are actively monitoring our network and can confirm that Exascale is not experiencing any issues related to Storm Éowyn. Our network remains stable and fully operational.

As an extra precaution, our Exascale Fleet is conducting regular checks on the network assets every few hours. There’s no need for concern—this is simply an additional step we’re taking to ensure continued stability during this time.

Update from Openreach
Openreach has informed us that their teams are extremely busy due to the ongoing disruption caused by Storm Éowyn. You can view their release here: https://openreach-comms.co.uk/cr/AQischCr0IoHGJzot7YH-IzPvLB6gigUY0TiFqorr8eGF11nfLq1-35Z6Rkuw_I

We appreciate your cooperation and understanding. If you have any questions or need further assistance, please reach out to our support team at support@exascale.co.uk.
Posted Jan 24, 2025 - 11:43 GMT