Loss of Hypervisor in Telford

Incident Report for Exascale

Resolved

All systems are now back to normal.
Posted Sep 13, 2025 - 23:19 BST

Monitoring

We have recovered all critical services and non-critical services will start to recover shortly.
Posted Sep 13, 2025 - 21:28 BST

Update

We are continuing to work on a fix for this issue.
Posted Sep 13, 2025 - 18:44 BST

Update

We have restored the majority of services, however we are currently rebuilding the hypervisor to restore Radius which is affecting national broadband circuits delivered over Openreach.
Posted Sep 13, 2025 - 18:44 BST

Update

We have introduced other DNS servers into the network, service should be starting to restore.
Posted Sep 13, 2025 - 18:01 BST

Identified

The DNS servers in Telford have failed due to being hosted on the Hypervisor cluster which has failed. We recommend setting your DNS servers to 8.8.8.8 or 4.4.4.4 to restore service while we resolve the issue.
Posted Sep 13, 2025 - 17:42 BST
This incident affected: Exascale - Full Fibre Networks (Telford, West Bromwich) and Exascale - Core and Edge Networks (Telford (TEL00)).