Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2025 - 22:00 GMT
Scheduled
These works are part of an overall network hardening schedule, to reduce the chance of future faults when entering the SEP and thus reduce the likelihood of unexpected customer outages. This particular work is to remake a badly degraded splicing-case that is leaving circuits vulnerable.
Traffic will traverse alternative paths during this window, albeit at higher latency.
Posted Mar 14, 2025 - 16:43 GMT
This scheduled maintenance affected: Exascale - Core and Edge Networks (London (LHR00), Wolverhampton (WLV00)).