Telford Stirchley - Off-net Openreach Down

Incident Report for Exascale

Resolved

This incident has been resolved.
Posted Sep 22, 2024 - 23:04 BST

Investigating

We have been informed that some connections in the Stirchley Telford area are currently down. This is effecting all networks in the area including Openreach etc.

We have investigated and this issue is out of our system and out of our control.
Posted Sep 21, 2024 - 21:22 BST
This incident affected: Exascale - Wholesale Services (Vodafone WDSL).